SiSOffRoad Forums  

Go Back   SiSOffRoad Forums > Tech & Fab > Tech Board

Reply
 
Thread Tools Display Modes
Old 08-27-2015, 03:18 PM   #1
chucky8400
 
chucky8400's Avatar
 
Join Date: Jun 2012
Posts: 12
chucky8400 is an unknown quantity at this point
Default 96 XJ Problems...HELP!

Alright guys, for all who don't know me i'm Charlie. I've got some really odd things happening with my jeep. So here's whats going on;
Problems
Running rough at idle sometimes. VERY ROUGH ACTUALLY
Code P0171; which could be caused by O2 sensor or Fuel injector?
Now here is the DOOZY one.... i start it up and put it into gear, start driving
and around ten miles an hour i turn any of the air on and its shifts into 2nd
or 3rd gear!!! I even had it stall on me one day cause i forgot i had the air
on and went to stop at a stop sign.
It also shifts funny going down the road, sometimes it doesn't like shifting
from 2nd to 3rd. On the highway it will ride in overdrive but as soon as i let
about 25% of the pedal off it shifts out of overdrive.

New Parts
TPS
Both O2 Sensors are almost new.
CPS was replaced a couple months ago with a used newer one.
I cleaned the throttle body along with the IAC valve.

Please help me guys.
__________________
Jeep xj + 194,000+ $225=
chucky8400 is offline   Reply With Quote
Old 08-27-2015, 03:57 PM   #2
Lycaon
 
Lycaon's Avatar
Resident Werewolf
 
Join Date: Oct 2007
Location: North Branford, CT
Posts: 3,113
Lycaon is an unknown quantity at this point
Send a message via AIM to Lycaon
Default

http://engine-codes.com/p0171_jeep.html
__________________
Wampa: 1998 Jeep Grand Cherokee 5.9 Limited
Berserker: 2005 Jeep Wrangler Rubicon Unlimited
Lycaon is offline   Reply With Quote
Old 08-28-2015, 09:00 AM   #3
chucky8400
 
chucky8400's Avatar
 
Join Date: Jun 2012
Posts: 12
chucky8400 is an unknown quantity at this point
Default

Thanks ill look into it more.
__________________
Jeep xj + 194,000+ $225=
chucky8400 is offline   Reply With Quote
Old 08-28-2015, 09:05 AM   #4
customcreationsllc
 
customcreationsllc's Avatar
 
Join Date: Jan 2009
Location: Naugatuck
Posts: 1,770
customcreationsllc is an unknown quantity at this point
Default

Hard to follow what you are saying.

Maybe there is a vacuum leak.
I think your air vents are vacuum controlled.
Try plugging up the vacuum line that goes into the cab.
__________________
RCrocs #123 Brown CJ-5
www.offroadcustomcreations.com

Sponsors:
Corbeau, Tom Wood, PSC, Polyperformance, Inner Air Lock, Miller Welds, Heavymetal Concepts
customcreationsllc is offline   Reply With Quote
Old 08-31-2015, 03:24 PM   #5
chucky8400
 
chucky8400's Avatar
 
Join Date: Jun 2012
Posts: 12
chucky8400 is an unknown quantity at this point
Default

Fixed. I found out I had a bad ground. So it was electrical. Thanks for the help guys!
__________________
Jeep xj + 194,000+ $225=
chucky8400 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:32 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.